Put server on line

Mar 29, 2010 at 2:22 PM

Hi friends... I know this is not direct related to you, but,  I've installed server and when I try access it, I get this error:

 

Server Error in '/FactoryService' Application.

Access is denied.

Description: An error occurred while accessing the resources required to serve this request. The server may not be configured for access to the requested URL.

Error message 401.2.: Unauthorized: Logon failed due to server configuration.  Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.  Contact the Web server's administrator for additional assistance.

 

I already gave permission to IIS guest account, asp.net guest account... but I can't make this work... someone there could point me out something ?

Developer
Mar 29, 2010 at 3:03 PM

Hi quicoli, probably it might get fixed by enabling Windows Authentication. I was having the same error and that fixed it.

  • Run inetmgr.exe (the IIS Management Console)
  • locate the ScrumFactory virtual directory in the navigation pane
  • select Authentication in the right view
  • right click Windows Authentication and pick Enable

http://cid-9e5d4c3be8afbb19.skydrive.live.com/self.aspx/Posts/ScrumFactoryWindowsAuth.PNG

Let me know if it helps

Mar 29, 2010 at 3:25 PM

Thank you!  It worked now :)

 

Mar 29, 2010 at 3:43 PM

Well,  it worked, not completely :(

I've installed Client. When I call client I configure the server address and define username and password. the client cant connect to server, but:

if I point my Firefox to server address, it raises a dialog asking user name and password. So I inform that and I can see on browser all methods from your webservice.... :/

What is wrong again??  :)

 

 

Developer
Mar 29, 2010 at 3:49 PM
Hi quicoli, let me tell you that Firefox does not get along well with Windows Authentication, in that cases, use IE -sigh, I never though I'd say this-
What do you mean by 'define username and password'? Where do you do that?

From: [email removed]
Sent: Monday, March 29, 2010 12:43 PM
Subject: Re: Put server on line [thescrumfactory:207637]

From: quicoli

Well, it worked, not completely :(

I've installed Client. When I call client I configure the server address and define username and password. the client cant connect to server, but:

if I point my Firefox to server address, it raises a dialog asking user name and password. So I inform that and I can see on browser all methods from your webservice.... :/

What is wrong again?? :)

Mar 29, 2010 at 4:02 PM

Well,

this is my scrum factory address: http://192.168.1.120/FactoryService/ProjectService.asmx

When I point that in IE/Firefox, a window requesting authentication appears. So I input a default username/password we use here and IE shows me all methods from web service. But I try do the same using Client... and doesn't work.

 

 

 

 

Developer
Mar 29, 2010 at 4:04 PM

Let me ask you one thing, are both your server and your client machine in the same Active Directory domain?

Mar 29, 2010 at 4:07 PM

No, they are not in the same domain. Client is a XBAP app?

Developer
Mar 29, 2010 at 4:11 PM

The client is a WPF desktop application, so it will use the credentials of the user that runs it. XBAP applications are something else, they are WPF apps but they run inside a browser window.

Thanks,

Mar 29, 2010 at 4:18 PM

OK, so, as my server and client are not in the same domain, how can I make this work ?

thanks!

Developer
Mar 29, 2010 at 5:03 PM

Hi quicoli, if you have access to the source code, find the file Client.xaml.cs and modify the SetUpService() method as I describe below.
I didn't test it since I made my own modifications to work with the application outside a domain, but I think this should work.

public static bool SetUpService()
{
 Service = new BadHabit.Factory.FactoryService.ProjectService();
 Service.Credentials = System.Net.CredentialCache.DefaultCredentials;
 Service.Proxy = null;


 try
 {
  Service.Credentials = new NetworkCredential("user", "password", "domain");
  Service.Url = FormatedServiceUrl;
 }
 catch (Exception ex)
 {
  BadHabit.Factory.Views.Error.ShowError(ex,
   BadHabit.Factory.Properties.Resources.COULD_NOT_CONNECT_TO_SERVER,
   BadHabit.Factory.Properties.Resources.Your_service_url_is_not_valid);
  return false;
 }

 return true;
}

Coordinator
Mar 30, 2010 at 12:52 AM

Hi quicoli,

You can also try disable WIndows Authentication and login using an access key.

To do that, disabel the Windows Authetication, and run the following SQL:

INSERT [factory].[Member] ([MemberId], [DefaultUnitName], [NickName], [FactoryOwnerRole], [ScrumMasterRole], [TeamRole], [ProductOwnerRole], [CommercialGuyRole], [EmailAccount], [ContactData], [Company], [ClientContactRole], [AccessKey], [QualityAssuranceRole]) VALUES (N'FACTORY\Quicoli', N'S.M.', N'Quicoli', 1, 1, 1, 1, 1, NULL, NULL, N'', 0, '1c26c15b-b285-4c57-8a56-c0537f988dcd ', 1)

It will create a user at the database name FACTORY\Quicoli with all permissions.

At the client, on the configuration window, at the Connection TAB, inform:

user: FACTORY\Quicoli

access key: 1c26c15b-b285-4c57-8a56-c0537f988dcd